Time-critical issue with HID/Mercury LP panels

January 14, 2020

HID/Mercury has notified Genetec that LP intelligent controllers (LP1501, LP1502, LP2500, LP4502) will experience schedule issues and will report time and date incorrectly following Leap Day, February 29, 2020.

Risk assessment 

This issue can potentially lead to granting and/or denying access outside of the programmed schedule, possibly leading to security risks.

Exceptions

EP series controllers and bridge products (M5, MS, and MI) are not impacted by this issue.

Recommendation

Mercury recommends upgrading all deployed LP intelligent controllers to firmware version 1.27.8.06.29 before March 1st, 2020.

Genetec customers will first need to upgrade to Genetec Softwire version 10.11 so that the Cloud Link can upgrade the LP Mercury panels to the correct version level 1.29.0, before March 1st, 2020.

Please note that because Genetec never used the legacy mode to integrate the Mercury LP panels in Security Center, all Mercury LP panels must be upgraded regardless of the Security Center version being used.

Mercury firmware 1.29.0 is now available for download on the Genetec Technical Assistance Portal (GTAP)

*You will be prompted to log in to the Genetec Portal. If you do not have login credentials, please email salesadmin@genetec.com for assistance.

The procedure for upgrading to these versions is listed below and can also be found in the Synergis Appliance Configuration Guide 10.11.

  1. Log in to the Synergis™ unit
  2. Click on Maintenance > Softwire upgrade

The current firmware version will be indicated.

3. In the file browser that opens, select the .sfw firmware file containing the new Mercury firmware, and click Open. The .sfw file must be located on your local drive.

4. Click on Upgrade now. The Synergis appliance will restart and the upgrade will take a few minutes.

5. From the Interface upgrade page, click on Apply recommended firmware.

The following confirmation message will be displayed: Upgrade completed successfully.

Future LP installations

We strongly recommend that all LP controllers, installed by June 1st, 2020, be upgraded with firmware version 1.29.

Questions?

For all additional inquiries or concerns please contact your system integrator or the Genetec Support team.

No Previous Articles

Next Article
Vulnerability affecting the Media Gateway role of Security Center
Vulnerability affecting the Media Gateway role of Security Center

This vulnerability affects the Media Gateway Role in its default configuration and can be used to access vi...